<!DOCTYPE html>
<html lang="en-GB" class="no-js">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="https://gmpg.org/xfn/11">
		<link rel="pingback" href="https://noenthuda.com/blog/xmlrpc.php">
		<script>(function(html){html.className = html.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script>
<title>Placing data labels in bar graphs &#8211; Pertinent Observations</title>
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Pertinent Observations &raquo; Feed" href="https://noenthuda.com/blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="Pertinent Observations &raquo; Comments Feed" href="https://noenthuda.com/blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Pertinent Observations &raquo; Placing data labels in bar graphs Comments Feed" href="https://noenthuda.com/blog/2020/05/01/placing-data-labels-in-bar-graphs/feed/" />
		<script>
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/noenthuda.com\/blog\/wp-includes\/js\/wp-emoji-release.min.js?ver=62b1783c20b4e78dd36fca13d0c8b566"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='twentysixteen-jetpack-css'  href='https://noenthuda.com/blog/wp-content/plugins/jetpack/modules/theme-tools/compat/twentysixteen.css?ver=8.4.2' media='all' />
<link rel='stylesheet' id='openid-css'  href='https://noenthuda.com/blog/wp-content/plugins/openid/f/openid.css?ver=519' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://noenthuda.com/blog/wp-includes/css/dist/block-library/style.min.css?ver=62b1783c20b4e78dd36fca13d0c8b566' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://noenthuda.com/blog/wp-includes/css/dist/block-library/theme.min.css?ver=62b1783c20b4e78dd36fca13d0c8b566' media='all' />
<link rel='stylesheet' id='twentysixteen-fonts-css'  href='https://fonts.googleapis.com/css?family=Merriweather%3A400%2C700%2C900%2C400italic%2C700italic%2C900italic%7CMontserrat%3A400%2C700%7CInconsolata%3A400&#038;subset=latin%2Clatin-ext&#038;display=fallback' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://noenthuda.com/blog/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' media='all' />
<link rel='stylesheet' id='twentysixteen-style-css'  href='https://noenthuda.com/blog/wp-content/themes/twentysixteen/style.css?ver=20190507' media='all' />
<link rel='stylesheet' id='twentysixteen-block-style-css'  href='https://noenthuda.com/blog/wp-content/themes/twentysixteen/css/blocks.css?ver=20190102' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='twentysixteen-ie-css'  href='https://noenthuda.com/blog/wp-content/themes/twentysixteen/css/ie.css?ver=20170530' media='all' />
<![endif]-->
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentysixteen-ie8-css'  href='https://noenthuda.com/blog/wp-content/themes/twentysixteen/css/ie8.css?ver=20170530' media='all' />
<![endif]-->
<!--[if lt IE 8]>
<link rel='stylesheet' id='twentysixteen-ie7-css'  href='https://noenthuda.com/blog/wp-content/themes/twentysixteen/css/ie7.css?ver=20170530' media='all' />
<![endif]-->
<link rel='stylesheet' id='social-logos-css'  href='https://noenthuda.com/blog/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://noenthuda.com/blog/wp-content/plugins/jetpack/css/jetpack.css?ver=8.4.2' media='all' />
<script src='https://noenthuda.com/blog/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script src='https://noenthuda.com/blog/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script src='https://noenthuda.com/blog/wp-content/plugins/openid/f/openid.js?ver=519'></script>
<!--[if lt IE 9]>
<script src='https://noenthuda.com/blog/wp-content/themes/twentysixteen/js/html5.js?ver=3.7.3'></script>
<![endif]-->
<script src='https://noenthuda.com/blog/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://noenthuda.com/blog/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://noenthuda.com/blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://noenthuda.com/blog/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='The corner Bhelpuri guy' href='https://noenthuda.com/blog/2020/04/30/the-corner-bhelpuri-guy/' />
<link rel="canonical" href="https://noenthuda.com/blog/2020/05/01/placing-data-labels-in-bar-graphs/" />
<link rel='shortlink' href='https://wp.me/p3LLi7-2zL' />
<link rel="alternate" type="application/json+oembed" href="https://noenthuda.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnoenthuda.com%2Fblog%2F2020%2F05%2F01%2Fplacing-data-labels-in-bar-graphs%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://noenthuda.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnoenthuda.com%2Fblog%2F2020%2F05%2F01%2Fplacing-data-labels-in-bar-graphs%2F&#038;format=xml" />

<!-- Bad Behavior 2.2.24 run time: 1.196 ms -->

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Placing data labels in bar graphs" />
<meta property="og:url" content="https://noenthuda.com/blog/2020/05/01/placing-data-labels-in-bar-graphs/" />
<meta property="og:description" content="If you think you&#8217;re a data visualisation junkie, it&#8217;s likely that you&#8217;ve read Edward Tufte&#8217;s Visual Display Of Quantitative Information. If you are only a casual observer of…" />
<meta property="article:published_time" content="2020-05-01T03:32:35+00:00" />
<meta property="article:modified_time" content="2020-05-01T03:32:35+00:00" />
<meta property="og:site_name" content="Pertinent Observations" />
<meta property="og:image" content="http://static1.squarespace.com/static/56713bf4dc5cb41142f28d1f/t/56fd4c83746fb9261146eed5/1459440776291/ClearOffTheTableMd.gif" />
<meta property="og:image:width" content="750" />
<meta property="og:image:height" content="563" />
<meta property="og:locale" content="en_GB" />
<meta name="twitter:creator" content="@karthiks" />
<meta name="twitter:text:title" content="Placing data labels in bar graphs" />
<meta name="twitter:card" content="summary" />

<!-- End Jetpack Open Graph Tags -->
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-4967586-1']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
</head>

<body class="post-template-default single single-post postid-9905 single-format-standard wp-embed-responsive group-blog">
<div id="page" class="site">
	<div class="site-inner">
		<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

		<header id="masthead" class="site-header" role="banner">
			<div class="site-header-main">
				<div class="site-branding">
					
											<p class="site-title"><a href="https://noenthuda.com/blog/" rel="home">Pertinent Observations</a></p>
										</div><!-- .site-branding -->

									<button id="menu-toggle" class="menu-toggle">Menu</button>

					<div id="site-header-menu" class="site-header-menu">
													<nav id="site-navigation" class="main-navigation" role="navigation" aria-label="Primary menu">
								<div class="menu-main-container"><ul id="menu-main" class="primary-menu"><li id="menu-item-6765" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6765"><a href="https://noenthuda.com/blog/contact/">Contact</a></li>
<li id="menu-item-6766" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6766"><a href="https://noenthuda.com/blog/about/">About</a></li>
<li id="menu-item-7573" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7573"><a href="https://noenthuda.com/blog/category/arbit/">arbit</a></li>
<li id="menu-item-7574" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7574"><a href="https://noenthuda.com/blog/category/business/">business</a></li>
<li id="menu-item-7575" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-7575"><a href="https://noenthuda.com/blog/category/data/">data</a></li>
<li id="menu-item-7576" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7576"><a href="https://noenthuda.com/blog/category/economics/">economics</a></li>
<li id="menu-item-7577" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7577"><a href="https://noenthuda.com/blog/category/fundaes/">fundaes</a></li>
<li id="menu-item-7578" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7578"><a href="https://noenthuda.com/blog/category/randomness/">randomness</a></li>
<li id="menu-item-7579" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7579"><a href="https://noenthuda.com/blog/category/religion/">religion</a></li>
<li id="menu-item-7580" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7580"><a href="https://noenthuda.com/blog/category/social-networks/">social networks</a></li>
</ul></div>							</nav><!-- .main-navigation -->
						
											</div><!-- .site-header-menu -->
							</div><!-- .site-header-main -->

					</header><!-- .site-header -->

		<div id="content" class="site-content">

<div id="primary" class="content-area">
	<main id="main" class="site-main" role="main">
		
<article id="post-9905" class="post-9905 post type-post status-publish format-standard hentry category-analytics category-data category-visualization tag-data-label tag-data-visualisation tag-ggplot2 tag-legend tag-positioning tag-r tag-tidy-data tag-tufte">
	<header class="entry-header">
		<h1 class="entry-title">Placing data labels in bar graphs</h1>	</header><!-- .entry-header -->

	
	
	<div class="entry-content">
		<p>If you think you&#8217;re a data visualisation junkie, it&#8217;s likely that you&#8217;ve read Edward Tufte&#8217;s <a href="https://www.amazon.co.uk/Visual-Display-Quantitative-Information/dp/0961392142/ref=pd_aw_sbs_14_1?_encoding=UTF8&amp;pd_rd_i=0961392142&amp;pd_rd_r=5754eb2f-76f8-11e8-8726-d91f82847179&amp;pd_rd_w=M25KE&amp;pd_rd_wg=kiso4&amp;pf_rd_i=mobile-dp-sims&amp;pf_rd_m=A3P5ROKL5A1OLE&amp;pf_rd_p=5587271662848339759&amp;pf_rd_r=ZDGEYHQE7P03Y5V3V0KD&amp;pf_rd_s=mobile-dp-sims&amp;pf_rd_t=40701&amp;psc=1&amp;refRID=ZDGEYHQE7P03Y5V3V0KD">Visual Display Of Quantitative Information</a>. If you are only a casual observer of the topic, you are likely to have <a href="https://www.darkhorseanalytics.com/blog/data-looks-better-naked">come across these gifs</a> that show you how to clean up a bar graph and a data table.</p>
<p><a href="https://www.darkhorseanalytics.com/blog/data-looks-better-naked"><img class="aligncenter size-large" src="https://images.squarespace-cdn.com/content/v1/56713bf4dc5cb41142f28d1f/1450306653111-70K5IT30R69NWPDIE1ZJ/ke17ZwdGBToddI8pDm48kPTmLCYI3azk0b44ISZKpQNZw-zPPgdn4jUwVcJE1ZvWQUxwkmyExglNqGp0IvTJZUJFbgE-7XRK3dMEBRBhUpzMx-NIgOy-55tVg9z7UZkVgiIW24uP_Lvr_-BmgSUFsZXzRgzYKtZb9_ZW_5JeO3Y/data-ink.gif?format=1500w" width="640" height="460" /></a></p>
<p><img class="alignnone size-large" src="https://static1.squarespace.com/static/56713bf4dc5cb41142f28d1f/t/56fd4c83746fb9261146eed5/1459440776291/ClearOffTheTableMd.gif" width="750" height="563" /></p>
<p>And if you are a real geek when it comes to visualisation, and you are the sort of person who likes long-form articles about the information technology industry, I&#8217;m sure you&#8217;ve come across Eugene Wei&#8217;s massive essay on &#8220;<a href="https://www.eugenewei.com/blog/2017/11/13/remove-the-legend">remove the legend to become one</a>&#8220;.</p>
<p>The idea in the last one is that when you have something like a line graph, a legend telling you which line represents what can be distracting, especially if you have too many lines. You need to constantly move your head back and forth between the chart and the table as you try to interpret it. So, Wei says, in order to &#8220;become a legend&#8221; (by presenting information that is easily consumable), you need to remove the legend.</p>
<p>My equivalent of that for bar graphs is to put data labels directly on the bar, rather than having the reader keep looking at a scale (the above gif with bar graphs also does this). It makes for easier reading, and by definition, the bar graph conveys the information on the relative sizes of the different data points as well.</p>
<p>There is one problem, though, especially when you&#8217;re drawing what my daughter calls &#8220;sleeping bar graphs&#8221; (horizontal) &#8211; where do you really put the text so that it is easily visible? This becomes especially important if you&#8217;re using a package like<a href="https://ggplot2.tidyverse.org"> R ggplot</a> where you have control over where to place the text, what size to use and so on.</p>
<p>The basic question is &#8211; do you place the label inside or outside the bar? I was grappling with this question yesterday while making some client chart. When I placed the labels inside the bar, I found that some of the labels couldn&#8217;t be displayed in full when the bars were too short. And since these were bars that were being generated programmatically, I had no clue beforehand how long the bars would be.</p>
<p>So I decided to put all the labels outside. This presented a different problem &#8211; with the long bars. The graph would automatically get cut off a little after the longest bar ended, so if you placed the text outside, then the labels on the longest bar couldn&#8217;t be seen! Again the graphs have to come out programmatically so when you&#8217;re making them you don&#8217;t know what the length of the longest bar will be.</p>
<p>I finally settled on this middle ground &#8211; if the bar is at least half as long as the longest bar in the chart set, then you put the label inside the bar. If the bar is shorter than half the longest bar, then you put the label outside the bar. And then, the text inside the bar is right-justified (so it ends just inside the end of the bar), and the text outside the bar is left-justified (so it starts exactly where the bar ends). And ggplot gives you enough flexibility to decide the justification (&#8216;hjust&#8217;) and colour of the text (I keep it white if it is inside the bar, black if outside), that the whole thing can be done programmatically, while producing nice and easy-to-understand bar graphs with nice labels.</p>
<p>Obviously I can&#8217;t share my client charts here, but here is one I made for the doubling days for covid-19 cases by district in India. I mean it&#8217;s not exactly what I said here, but comes close (the manual element here is a bit more).</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">In fact, there is wide divergence within states as well<br />Within states, we see high divergence in doubling rates across districts <a href="https://t.co/jIU9CmitRx">pic.twitter.com/jIU9CmitRx</a></p>
<p>&mdash; Karthik (@karthiks) <a href="https://twitter.com/karthiks/status/1256048284172500994?ref_src=twsrc%5Etfw">May 1, 2020</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button" href="https://noenthuda.com/blog/2020/05/01/placing-data-labels-in-bar-graphs/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-pocket"><div class="pocket_button"><a href="https://getpocket.com/save" class="pocket-btn" data-lang="en" data-save-url="https://noenthuda.com/blog/2020/05/01/placing-data-labels-in-bar-graphs/" data-pocket-count="horizontal" >Pocket</a></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://noenthuda.com/blog/2020/05/01/placing-data-labels-in-bar-graphs/" data-text="Placing data labels in bar graphs" data-via="karthiks" >Tweet</a></li><li class="share-facebook"><div class="fb-share-button" data-href="https://noenthuda.com/blog/2020/05/01/placing-data-labels-in-bar-graphs/" data-layout="button_count"></div></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button" href="https://noenthuda.com/blog/2020/05/01/placing-data-labels-in-bar-graphs/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-linkedin"><div class="linkedin_button"><script type="in/share" data-url="https://noenthuda.com/blog/2020/05/01/placing-data-labels-in-bar-graphs/" data-counter="right"></script></div></li><li class="share-reddit"><div class="reddit_button"><iframe src="https://www.reddit.com/static/button/button1.html?newwindow=true&width=120&amp;url=https%3A%2F%2Fnoenthuda.com%2Fblog%2F2020%2F05%2F01%2Fplacing-data-labels-in-bar-graphs%2F&amp;title=Placing%20data%20labels%20in%20bar%20graphs" height="22" width="120" scrolling="no" frameborder="0"></iframe></div></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-55712215-9905-5eabf258cd2bf' data-src='https://widgets.wp.com/likes/#blog_id=55712215&amp;post_id=9905&amp;origin=noenthuda.com&amp;obj_id=55712215-9905-5eabf258cd2bf' data-name='like-post-frame-55712215-9905-5eabf258cd2bf'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>	</div><!-- .entry-content -->

	<footer class="entry-footer">
		<span class="byline"><span class="author vcard"><img alt='' src='https://secure.gravatar.com/avatar/b8af9e1429e8886a4b26a805c933f8ef?s=49&#038;d=mm&#038;r=x' srcset='https://secure.gravatar.com/avatar/b8af9e1429e8886a4b26a805c933f8ef?s=98&#038;d=mm&#038;r=x 2x' class='avatar avatar-49 photo' height='49' width='49' /><span class="screen-reader-text">Author </span> <a class="url fn n" href="https://noenthuda.com/blog/author/skimpy/">SK</a></span></span><span class="posted-on"><span class="screen-reader-text">Posted on </span><a href="https://noenthuda.com/blog/2020/05/01/placing-data-labels-in-bar-graphs/" rel="bookmark"><time class="entry-date published updated" datetime="2020-05-01T04:32:35+01:00">May 1, 2020</time></a></span><span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://noenthuda.com/blog/category/analytics/" rel="category tag">analytics</a>, <a href="https://noenthuda.com/blog/category/data/" rel="category tag">data</a>, <a href="https://noenthuda.com/blog/category/visualization/" rel="category tag">visualization</a></span><span class="tags-links"><span class="screen-reader-text">Tags </span><a href="https://noenthuda.com/blog/tag/data-label/" rel="tag">data label</a>, <a href="https://noenthuda.com/blog/tag/data-visualisation/" rel="tag">data visualisation</a>, <a href="https://noenthuda.com/blog/tag/ggplot2/" rel="tag">ggplot2</a>, <a href="https://noenthuda.com/blog/tag/legend/" rel="tag">legend</a>, <a href="https://noenthuda.com/blog/tag/positioning/" rel="tag">positioning</a>, <a href="https://noenthuda.com/blog/tag/r/" rel="tag">R</a>, <a href="https://noenthuda.com/blog/tag/tidy-data/" rel="tag">tidy data</a>, <a href="https://noenthuda.com/blog/tag/tufte/" rel="tag">tufte</a></span>			</footer><!-- .entry-footer -->
</article><!-- #post-9905 -->

<div id="comments" class="comments-area">

	
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Put Comment					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/2020/05/01/placing-data-labels-in-bar-graphs/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=55712215&#038;postid=9905&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Put+Comment&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_GB&#038;jetpack_version=8.4.2&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=962e02d4fab69ad94de37c2440e3c023fc5e9d73#parent=https%3A%2F%2Fnoenthuda.com%2Fblog%2F2020%2F05%2F01%2Fplacing-data-labels-in-bar-graphs%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- .comments-area -->

	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://noenthuda.com/blog/2020/04/30/the-corner-bhelpuri-guy/" rel="prev"><span class="meta-nav" aria-hidden="true">Previous</span> <span class="screen-reader-text">Previous post:</span> <span class="post-title">The corner Bhelpuri guy</span></a></div></div>
	</nav>
	</main><!-- .site-main -->

	<aside id="content-bottom-widgets" class="content-bottom-widgets" role="complementary">
			<div class="widget-area">
			<section id="meta-3" class="widget widget_meta"><h2 class="widget-title">Meta</h2>			<ul>
						<li><a href="https://noenthuda.com/blog/wp-login.php">Log in</a></li>
			<li><a href="https://noenthuda.com/blog/feed/">Entries feed</a></li>
			<li><a href="https://noenthuda.com/blog/comments/feed/">Comments feed</a></li>
			<li><a href="https://en-gb.wordpress.org/">WordPress.org</a></li>			</ul>
			</section>		</div><!-- .widget-area -->
	
			<div class="widget-area">
			<section id="blog_subscription-4" class="widget widget_blog_subscription jetpack_subscription_widget"><h2 class="widget-title">Subscribe to Blog via Email</h2>
            <form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-4">
				                    <div id="subscribe-text"><p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
</div><p>Join 6,720 other subscribers.</p>
                    <p id="subscribe-email">
                        <label id="jetpack-subscribe-label"
                               class="screen-reader-text"
                               for="subscribe-field-blog_subscription-4">
							Email Address                        </label>
                        <input type="email" name="email" required="required" class="required"
                               value=""
                               id="subscribe-field-blog_subscription-4"
                               placeholder="Email Address"/>
                    </p>

                    <p id="subscribe-submit">
                        <input type="hidden" name="action" value="subscribe"/>
                        <input type="hidden" name="source" value="https://noenthuda.com/blog/2020/05/01/placing-data-labels-in-bar-graphs/"/>
                        <input type="hidden" name="sub-type" value="widget"/>
                        <input type="hidden" name="redirect_fragment" value="blog_subscription-4"/>
						                        <button type="submit"
	                        		                    	                        name="jetpack_subscriptions_widget"
	                    >
	                        Subscribe                        </button>
                    </p>
				            </form>
		
</section>		<section id="recent-posts-3" class="widget widget_recent_entries">		<h2 class="widget-title">Recent Posts</h2>		<ul>
											<li>
					<a href="https://noenthuda.com/blog/2020/05/01/placing-data-labels-in-bar-graphs/" aria-current="page">Placing data labels in bar graphs</a>
									</li>
											<li>
					<a href="https://noenthuda.com/blog/2020/04/30/the-corner-bhelpuri-guy/">The corner Bhelpuri guy</a>
									</li>
											<li>
					<a href="https://noenthuda.com/blog/2020/04/29/verandahs/">Verandahs</a>
									</li>
											<li>
					<a href="https://noenthuda.com/blog/2020/04/29/fulfilling-needs/">Fulfilling needs</a>
									</li>
											<li>
					<a href="https://noenthuda.com/blog/2020/04/27/post-covid-stimulus/">Post-Covid Stimulus</a>
									</li>
											<li>
					<a href="https://noenthuda.com/blog/2020/04/24/peanut-butter/">Peanut Butter</a>
									</li>
											<li>
					<a href="https://noenthuda.com/blog/2020/04/24/tests-per-positive-case/">Tests per positive case</a>
									</li>
											<li>
					<a href="https://noenthuda.com/blog/2020/04/22/zoom-in-zoom-out/">Zoom in, zoom out</a>
									</li>
											<li>
					<a href="https://noenthuda.com/blog/2020/04/21/gully-cricket-with-a-test-cricketer/">Gully Cricket With A Test Cricketer</a>
									</li>
											<li>
					<a href="https://noenthuda.com/blog/2020/04/18/diamonds-and-rust/">Diamonds and Rust</a>
									</li>
					</ul>
		</section><section id="archives-4" class="widget widget_archive"><h2 class="widget-title">Archives</h2>		<label class="screen-reader-text" for="archives-dropdown-4">Archives</label>
		<select id="archives-dropdown-4" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://noenthuda.com/blog/2020/05/'> May 2020 &nbsp;(1)</option>
	<option value='https://noenthuda.com/blog/2020/04/'> April 2020 &nbsp;(19)</option>
	<option value='https://noenthuda.com/blog/2020/03/'> March 2020 &nbsp;(14)</option>
	<option value='https://noenthuda.com/blog/2020/02/'> February 2020 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2020/01/'> January 2020 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2019/12/'> December 2019 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2019/11/'> November 2019 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2019/10/'> October 2019 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2019/09/'> September 2019 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2019/08/'> August 2019 &nbsp;(15)</option>
	<option value='https://noenthuda.com/blog/2019/07/'> July 2019 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2019/05/'> May 2019 &nbsp;(5)</option>
	<option value='https://noenthuda.com/blog/2019/04/'> April 2019 &nbsp;(3)</option>
	<option value='https://noenthuda.com/blog/2019/03/'> March 2019 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2019/02/'> February 2019 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2019/01/'> January 2019 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2018/12/'> December 2018 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2018/11/'> November 2018 &nbsp;(14)</option>
	<option value='https://noenthuda.com/blog/2018/10/'> October 2018 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2018/09/'> September 2018 &nbsp;(27)</option>
	<option value='https://noenthuda.com/blog/2018/08/'> August 2018 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2018/07/'> July 2018 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2018/06/'> June 2018 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2018/05/'> May 2018 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2018/04/'> April 2018 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2018/03/'> March 2018 &nbsp;(4)</option>
	<option value='https://noenthuda.com/blog/2018/02/'> February 2018 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2018/01/'> January 2018 &nbsp;(5)</option>
	<option value='https://noenthuda.com/blog/2017/12/'> December 2017 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2017/11/'> November 2017 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2017/10/'> October 2017 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2017/09/'> September 2017 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2017/08/'> August 2017 &nbsp;(5)</option>
	<option value='https://noenthuda.com/blog/2017/07/'> July 2017 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2017/06/'> June 2017 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2017/05/'> May 2017 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2017/04/'> April 2017 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2017/03/'> March 2017 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2017/02/'> February 2017 &nbsp;(4)</option>
	<option value='https://noenthuda.com/blog/2017/01/'> January 2017 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2016/12/'> December 2016 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2016/11/'> November 2016 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2016/10/'> October 2016 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2016/09/'> September 2016 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2016/08/'> August 2016 &nbsp;(17)</option>
	<option value='https://noenthuda.com/blog/2016/07/'> July 2016 &nbsp;(4)</option>
	<option value='https://noenthuda.com/blog/2016/06/'> June 2016 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2016/05/'> May 2016 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2016/04/'> April 2016 &nbsp;(17)</option>
	<option value='https://noenthuda.com/blog/2016/03/'> March 2016 &nbsp;(17)</option>
	<option value='https://noenthuda.com/blog/2016/02/'> February 2016 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2016/01/'> January 2016 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2015/12/'> December 2015 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2015/11/'> November 2015 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2015/10/'> October 2015 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2015/09/'> September 2015 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2015/08/'> August 2015 &nbsp;(17)</option>
	<option value='https://noenthuda.com/blog/2015/07/'> July 2015 &nbsp;(20)</option>
	<option value='https://noenthuda.com/blog/2015/06/'> June 2015 &nbsp;(23)</option>
	<option value='https://noenthuda.com/blog/2015/05/'> May 2015 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2015/04/'> April 2015 &nbsp;(20)</option>
	<option value='https://noenthuda.com/blog/2015/03/'> March 2015 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2015/02/'> February 2015 &nbsp;(24)</option>
	<option value='https://noenthuda.com/blog/2015/01/'> January 2015 &nbsp;(35)</option>
	<option value='https://noenthuda.com/blog/2014/12/'> December 2014 &nbsp;(51)</option>
	<option value='https://noenthuda.com/blog/2014/11/'> November 2014 &nbsp;(32)</option>
	<option value='https://noenthuda.com/blog/2014/10/'> October 2014 &nbsp;(35)</option>
	<option value='https://noenthuda.com/blog/2014/09/'> September 2014 &nbsp;(30)</option>
	<option value='https://noenthuda.com/blog/2014/08/'> August 2014 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2014/07/'> July 2014 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2014/06/'> June 2014 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2014/05/'> May 2014 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2014/04/'> April 2014 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2014/03/'> March 2014 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2014/02/'> February 2014 &nbsp;(16)</option>
	<option value='https://noenthuda.com/blog/2014/01/'> January 2014 &nbsp;(17)</option>
	<option value='https://noenthuda.com/blog/2013/12/'> December 2013 &nbsp;(20)</option>
	<option value='https://noenthuda.com/blog/2013/11/'> November 2013 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2013/10/'> October 2013 &nbsp;(24)</option>
	<option value='https://noenthuda.com/blog/2013/09/'> September 2013 &nbsp;(27)</option>
	<option value='https://noenthuda.com/blog/2013/08/'> August 2013 &nbsp;(19)</option>
	<option value='https://noenthuda.com/blog/2013/07/'> July 2013 &nbsp;(17)</option>
	<option value='https://noenthuda.com/blog/2013/06/'> June 2013 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2013/05/'> May 2013 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2013/04/'> April 2013 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2013/03/'> March 2013 &nbsp;(16)</option>
	<option value='https://noenthuda.com/blog/2013/02/'> February 2013 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2013/01/'> January 2013 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2012/12/'> December 2012 &nbsp;(4)</option>
	<option value='https://noenthuda.com/blog/2012/11/'> November 2012 &nbsp;(1)</option>
	<option value='https://noenthuda.com/blog/2012/10/'> October 2012 &nbsp;(2)</option>
	<option value='https://noenthuda.com/blog/2012/09/'> September 2012 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2012/08/'> August 2012 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2012/07/'> July 2012 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2012/06/'> June 2012 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2012/04/'> April 2012 &nbsp;(4)</option>
	<option value='https://noenthuda.com/blog/2012/03/'> March 2012 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2012/02/'> February 2012 &nbsp;(3)</option>
	<option value='https://noenthuda.com/blog/2012/01/'> January 2012 &nbsp;(4)</option>
	<option value='https://noenthuda.com/blog/2011/12/'> December 2011 &nbsp;(23)</option>
	<option value='https://noenthuda.com/blog/2011/11/'> November 2011 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2011/10/'> October 2011 &nbsp;(26)</option>
	<option value='https://noenthuda.com/blog/2011/09/'> September 2011 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2011/08/'> August 2011 &nbsp;(22)</option>
	<option value='https://noenthuda.com/blog/2011/07/'> July 2011 &nbsp;(14)</option>
	<option value='https://noenthuda.com/blog/2011/06/'> June 2011 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2011/05/'> May 2011 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2011/04/'> April 2011 &nbsp;(16)</option>
	<option value='https://noenthuda.com/blog/2011/03/'> March 2011 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2011/02/'> February 2011 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2011/01/'> January 2011 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2010/12/'> December 2010 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2010/11/'> November 2010 &nbsp;(4)</option>
	<option value='https://noenthuda.com/blog/2010/10/'> October 2010 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2010/09/'> September 2010 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2010/08/'> August 2010 &nbsp;(4)</option>
	<option value='https://noenthuda.com/blog/2010/07/'> July 2010 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2010/06/'> June 2010 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2010/05/'> May 2010 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2010/04/'> April 2010 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2010/03/'> March 2010 &nbsp;(17)</option>
	<option value='https://noenthuda.com/blog/2010/02/'> February 2010 &nbsp;(5)</option>
	<option value='https://noenthuda.com/blog/2010/01/'> January 2010 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2009/12/'> December 2009 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2009/11/'> November 2009 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2009/10/'> October 2009 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2009/09/'> September 2009 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2009/08/'> August 2009 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2009/07/'> July 2009 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2009/06/'> June 2009 &nbsp;(14)</option>
	<option value='https://noenthuda.com/blog/2009/05/'> May 2009 &nbsp;(15)</option>
	<option value='https://noenthuda.com/blog/2009/04/'> April 2009 &nbsp;(19)</option>
	<option value='https://noenthuda.com/blog/2009/03/'> March 2009 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2009/02/'> February 2009 &nbsp;(19)</option>
	<option value='https://noenthuda.com/blog/2009/01/'> January 2009 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2008/12/'> December 2008 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2008/11/'> November 2008 &nbsp;(15)</option>
	<option value='https://noenthuda.com/blog/2008/10/'> October 2008 &nbsp;(22)</option>
	<option value='https://noenthuda.com/blog/2008/09/'> September 2008 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2008/08/'> August 2008 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2008/07/'> July 2008 &nbsp;(35)</option>
	<option value='https://noenthuda.com/blog/2008/06/'> June 2008 &nbsp;(24)</option>
	<option value='https://noenthuda.com/blog/2008/05/'> May 2008 &nbsp;(34)</option>
	<option value='https://noenthuda.com/blog/2008/04/'> April 2008 &nbsp;(27)</option>
	<option value='https://noenthuda.com/blog/2008/03/'> March 2008 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2008/02/'> February 2008 &nbsp;(31)</option>
	<option value='https://noenthuda.com/blog/2008/01/'> January 2008 &nbsp;(25)</option>
	<option value='https://noenthuda.com/blog/2007/12/'> December 2007 &nbsp;(22)</option>
	<option value='https://noenthuda.com/blog/2007/11/'> November 2007 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2007/10/'> October 2007 &nbsp;(15)</option>
	<option value='https://noenthuda.com/blog/2007/09/'> September 2007 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2007/08/'> August 2007 &nbsp;(19)</option>
	<option value='https://noenthuda.com/blog/2007/07/'> July 2007 &nbsp;(21)</option>
	<option value='https://noenthuda.com/blog/2007/06/'> June 2007 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2007/05/'> May 2007 &nbsp;(21)</option>
	<option value='https://noenthuda.com/blog/2007/04/'> April 2007 &nbsp;(20)</option>
	<option value='https://noenthuda.com/blog/2007/03/'> March 2007 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2007/02/'> February 2007 &nbsp;(19)</option>
	<option value='https://noenthuda.com/blog/2007/01/'> January 2007 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2006/12/'> December 2006 &nbsp;(14)</option>
	<option value='https://noenthuda.com/blog/2006/11/'> November 2006 &nbsp;(22)</option>
	<option value='https://noenthuda.com/blog/2006/10/'> October 2006 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2006/09/'> September 2006 &nbsp;(15)</option>
	<option value='https://noenthuda.com/blog/2006/08/'> August 2006 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2006/07/'> July 2006 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2006/06/'> June 2006 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2006/05/'> May 2006 &nbsp;(15)</option>
	<option value='https://noenthuda.com/blog/2006/04/'> April 2006 &nbsp;(30)</option>
	<option value='https://noenthuda.com/blog/2006/03/'> March 2006 &nbsp;(24)</option>
	<option value='https://noenthuda.com/blog/2006/02/'> February 2006 &nbsp;(41)</option>
	<option value='https://noenthuda.com/blog/2006/01/'> January 2006 &nbsp;(20)</option>
	<option value='https://noenthuda.com/blog/2005/12/'> December 2005 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2005/11/'> November 2005 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2005/10/'> October 2005 &nbsp;(24)</option>
	<option value='https://noenthuda.com/blog/2005/09/'> September 2005 &nbsp;(26)</option>
	<option value='https://noenthuda.com/blog/2005/08/'> August 2005 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2005/07/'> July 2005 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2005/06/'> June 2005 &nbsp;(19)</option>
	<option value='https://noenthuda.com/blog/2005/05/'> May 2005 &nbsp;(20)</option>
	<option value='https://noenthuda.com/blog/2005/04/'> April 2005 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2005/03/'> March 2005 &nbsp;(16)</option>
	<option value='https://noenthuda.com/blog/2005/02/'> February 2005 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2005/01/'> January 2005 &nbsp;(4)</option>
	<option value='https://noenthuda.com/blog/2004/12/'> December 2004 &nbsp;(1)</option>
	<option value='https://noenthuda.com/blog/2004/11/'> November 2004 &nbsp;(3)</option>
	<option value='https://noenthuda.com/blog/2004/10/'> October 2004 &nbsp;(2)</option>
	<option value='https://noenthuda.com/blog/2004/07/'> July 2004 &nbsp;(1)</option>

		</select>

<script>
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-4" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>

		</section><section id="top-posts-2" class="widget widget_top-posts"><h2 class="widget-title">Top Posts &amp; Pages</h2><ul>				<li>
					<a href="https://noenthuda.com/blog/2020/04/30/the-corner-bhelpuri-guy/" class="bump-view" data-bump-view="tp">The corner Bhelpuri guy</a>					</li>
								<li>
					<a href="https://noenthuda.com/blog/2020/04/29/verandahs/" class="bump-view" data-bump-view="tp">Verandahs</a>					</li>
								<li>
					<a href="https://noenthuda.com/blog/2020/05/01/placing-data-labels-in-bar-graphs/" class="bump-view" data-bump-view="tp" aria-current="page">Placing data labels in bar graphs</a>					</li>
								<li>
					<a href="https://noenthuda.com/blog/2020/04/29/fulfilling-needs/" class="bump-view" data-bump-view="tp">Fulfilling needs</a>					</li>
								<li>
					<a href="https://noenthuda.com/blog/2020/04/24/tests-per-positive-case/" class="bump-view" data-bump-view="tp">Tests per positive case</a>					</li>
				</ul></section><section id="categories-5" class="widget widget_categories"><h2 class="widget-title">Categories</h2><form action="https://noenthuda.com/blog" method="get"><label class="screen-reader-text" for="cat">Categories</label><select  name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="6660">analytics&nbsp;&nbsp;(68)</option>
	<option class="level-0" value="5">arbit&nbsp;&nbsp;(730)</option>
	<option class="level-0" value="7699">baby&nbsp;&nbsp;(28)</option>
	<option class="level-0" value="12">bangalore&nbsp;&nbsp;(130)</option>
	<option class="level-0" value="4">blogging&nbsp;&nbsp;(62)</option>
	<option class="level-0" value="6661">book review&nbsp;&nbsp;(6)</option>
	<option class="level-0" value="27">books&nbsp;&nbsp;(60)</option>
	<option class="level-0" value="7">business&nbsp;&nbsp;(269)</option>
	<option class="level-1" value="34">&nbsp;&nbsp;&nbsp;retail&nbsp;&nbsp;(49)</option>
	<option class="level-0" value="6504">Business School WAG&nbsp;&nbsp;(3)</option>
	<option class="level-0" value="17">computer science&nbsp;&nbsp;(43)</option>
	<option class="level-0" value="6662">data&nbsp;&nbsp;(47)</option>
	<option class="level-0" value="11">descriptive&nbsp;&nbsp;(115)</option>
	<option class="level-0" value="6">economics&nbsp;&nbsp;(243)</option>
	<option class="level-0" value="39">education&nbsp;&nbsp;(57)</option>
	<option class="level-0" value="9">entertainment&nbsp;&nbsp;(71)</option>
	<option class="level-1" value="10">&nbsp;&nbsp;&nbsp;movies&nbsp;&nbsp;(31)</option>
	<option class="level-1" value="24">&nbsp;&nbsp;&nbsp;music&nbsp;&nbsp;(21)</option>
	<option class="level-0" value="7700">fatherhood&nbsp;&nbsp;(17)</option>
	<option class="level-0" value="42">favourites&nbsp;&nbsp;(6)</option>
	<option class="level-0" value="23">finance&nbsp;&nbsp;(166)</option>
	<option class="level-1" value="36">&nbsp;&nbsp;&nbsp;banking&nbsp;&nbsp;(23)</option>
	<option class="level-1" value="33">&nbsp;&nbsp;&nbsp;investment banking&nbsp;&nbsp;(54)</option>
	<option class="level-0" value="25">food&nbsp;&nbsp;(127)</option>
	<option class="level-0" value="20">fundaes&nbsp;&nbsp;(413)</option>
	<option class="level-0" value="3">general&nbsp;&nbsp;(696)</option>
	<option class="level-0" value="4430">history&nbsp;&nbsp;(5)</option>
	<option class="level-0" value="19">IIM&nbsp;&nbsp;(42)</option>
	<option class="level-0" value="18">IIT&nbsp;&nbsp;(45)</option>
	<option class="level-0" value="14">infrastructure&nbsp;&nbsp;(57)</option>
	<option class="level-0" value="21">language&nbsp;&nbsp;(39)</option>
	<option class="level-0" value="7880">London&nbsp;&nbsp;(4)</option>
	<option class="level-0" value="6663">mathematics&nbsp;&nbsp;(15)</option>
	<option class="level-0" value="38">media&nbsp;&nbsp;(35)</option>
	<option class="level-0" value="6802">Non-Quant&nbsp;&nbsp;(34)</option>
	<option class="level-0" value="6664">organization&nbsp;&nbsp;(7)</option>
	<option class="level-0" value="16">personal&nbsp;&nbsp;(314)</option>
	<option class="level-0" value="13">photowalk&nbsp;&nbsp;(16)</option>
	<option class="level-0" value="6665">platforms&nbsp;&nbsp;(54)</option>
	<option class="level-0" value="30">politics&nbsp;&nbsp;(137)</option>
	<option class="level-1" value="35">&nbsp;&nbsp;&nbsp;karnataka elections&nbsp;&nbsp;(12)</option>
	<option class="level-0" value="6666">Pricing&nbsp;&nbsp;(37)</option>
	<option class="level-0" value="26">quizzing&nbsp;&nbsp;(14)</option>
	<option class="level-0" value="15">randomness&nbsp;&nbsp;(88)</option>
	<option class="level-0" value="7051">regulation&nbsp;&nbsp;(9)</option>
	<option class="level-0" value="37">relationships&nbsp;&nbsp;(116)</option>
	<option class="level-0" value="31">religion&nbsp;&nbsp;(89)</option>
	<option class="level-0" value="4293">science&nbsp;&nbsp;(24)</option>
	<option class="level-0" value="5032">social networks&nbsp;&nbsp;(38)</option>
	<option class="level-0" value="8">sport&nbsp;&nbsp;(135)</option>
	<option class="level-1" value="44">&nbsp;&nbsp;&nbsp;contract bridge&nbsp;&nbsp;(3)</option>
	<option class="level-1" value="22">&nbsp;&nbsp;&nbsp;cricket&nbsp;&nbsp;(51)</option>
	<option class="level-2" value="41">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;ipl&nbsp;&nbsp;(14)</option>
	<option class="level-1" value="32">&nbsp;&nbsp;&nbsp;football&nbsp;&nbsp;(56)</option>
	<option class="level-1" value="28">&nbsp;&nbsp;&nbsp;tennis&nbsp;&nbsp;(4)</option>
	<option class="level-0" value="6667">sports analytics&nbsp;&nbsp;(29)</option>
	<option class="level-0" value="1935">studs and fighters&nbsp;&nbsp;(27)</option>
	<option class="level-0" value="3805">tank&nbsp;&nbsp;(42)</option>
	<option class="level-0" value="40">technology&nbsp;&nbsp;(48)</option>
	<option class="level-0" value="3144">travel&nbsp;&nbsp;(69)</option>
	<option class="level-0" value="1">Uncategorized&nbsp;&nbsp;(234)</option>
	<option class="level-0" value="6668">visualization&nbsp;&nbsp;(16)</option>
	<option class="level-0" value="29">work&nbsp;&nbsp;(133)</option>
</select>
</form>
<script>
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

			</section>		</div><!-- .widget-area -->
	</aside><!-- .content-bottom-widgets -->

</div><!-- .content-area -->


	<aside id="secondary" class="sidebar widget-area" role="complementary">
		<section id="blog_subscription-4" class="widget widget_blog_subscription jetpack_subscription_widget"><h2 class="widget-title">Subscribe to Blog via Email</h2>
            <form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-4">
				                    <div id="subscribe-text"><p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
</div><p>Join 6,720 other subscribers.</p>
                    <p id="subscribe-email">
                        <label id="jetpack-subscribe-label"
                               class="screen-reader-text"
                               for="subscribe-field-blog_subscription-4">
							Email Address                        </label>
                        <input type="email" name="email" required="required" class="required"
                               value=""
                               id="subscribe-field-blog_subscription-4"
                               placeholder="Email Address"/>
                    </p>

                    <p id="subscribe-submit">
                        <input type="hidden" name="action" value="subscribe"/>
                        <input type="hidden" name="source" value="https://noenthuda.com/blog/2020/05/01/placing-data-labels-in-bar-graphs/"/>
                        <input type="hidden" name="sub-type" value="widget"/>
                        <input type="hidden" name="redirect_fragment" value="blog_subscription-4"/>
						                        <button type="submit"
	                        		                    	                        name="jetpack_subscriptions_widget"
	                    >
	                        Subscribe                        </button>
                    </p>
				            </form>
		
</section><section id="search-7" class="widget widget_search">
<form role="search" method="get" class="search-form" action="https://noenthuda.com/blog/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
	</label>
	<button type="submit" class="search-submit"><span class="screen-reader-text">Search</span></button>
</form>
</section>		<section id="recent-posts-3" class="widget widget_recent_entries">		<h2 class="widget-title">Recent Posts</h2>		<ul>
											<li>
					<a href="https://noenthuda.com/blog/2020/05/01/placing-data-labels-in-bar-graphs/" aria-current="page">Placing data labels in bar graphs</a>
									</li>
											<li>
					<a href="https://noenthuda.com/blog/2020/04/30/the-corner-bhelpuri-guy/">The corner Bhelpuri guy</a>
									</li>
											<li>
					<a href="https://noenthuda.com/blog/2020/04/29/verandahs/">Verandahs</a>
									</li>
											<li>
					<a href="https://noenthuda.com/blog/2020/04/29/fulfilling-needs/">Fulfilling needs</a>
									</li>
											<li>
					<a href="https://noenthuda.com/blog/2020/04/27/post-covid-stimulus/">Post-Covid Stimulus</a>
									</li>
											<li>
					<a href="https://noenthuda.com/blog/2020/04/24/peanut-butter/">Peanut Butter</a>
									</li>
											<li>
					<a href="https://noenthuda.com/blog/2020/04/24/tests-per-positive-case/">Tests per positive case</a>
									</li>
											<li>
					<a href="https://noenthuda.com/blog/2020/04/22/zoom-in-zoom-out/">Zoom in, zoom out</a>
									</li>
											<li>
					<a href="https://noenthuda.com/blog/2020/04/21/gully-cricket-with-a-test-cricketer/">Gully Cricket With A Test Cricketer</a>
									</li>
											<li>
					<a href="https://noenthuda.com/blog/2020/04/18/diamonds-and-rust/">Diamonds and Rust</a>
									</li>
					</ul>
		</section><section id="archives-4" class="widget widget_archive"><h2 class="widget-title">Archives</h2>		<label class="screen-reader-text" for="archives-dropdown-4">Archives</label>
		<select id="archives-dropdown-4" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://noenthuda.com/blog/2020/05/'> May 2020 &nbsp;(1)</option>
	<option value='https://noenthuda.com/blog/2020/04/'> April 2020 &nbsp;(19)</option>
	<option value='https://noenthuda.com/blog/2020/03/'> March 2020 &nbsp;(14)</option>
	<option value='https://noenthuda.com/blog/2020/02/'> February 2020 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2020/01/'> January 2020 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2019/12/'> December 2019 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2019/11/'> November 2019 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2019/10/'> October 2019 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2019/09/'> September 2019 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2019/08/'> August 2019 &nbsp;(15)</option>
	<option value='https://noenthuda.com/blog/2019/07/'> July 2019 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2019/05/'> May 2019 &nbsp;(5)</option>
	<option value='https://noenthuda.com/blog/2019/04/'> April 2019 &nbsp;(3)</option>
	<option value='https://noenthuda.com/blog/2019/03/'> March 2019 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2019/02/'> February 2019 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2019/01/'> January 2019 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2018/12/'> December 2018 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2018/11/'> November 2018 &nbsp;(14)</option>
	<option value='https://noenthuda.com/blog/2018/10/'> October 2018 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2018/09/'> September 2018 &nbsp;(27)</option>
	<option value='https://noenthuda.com/blog/2018/08/'> August 2018 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2018/07/'> July 2018 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2018/06/'> June 2018 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2018/05/'> May 2018 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2018/04/'> April 2018 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2018/03/'> March 2018 &nbsp;(4)</option>
	<option value='https://noenthuda.com/blog/2018/02/'> February 2018 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2018/01/'> January 2018 &nbsp;(5)</option>
	<option value='https://noenthuda.com/blog/2017/12/'> December 2017 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2017/11/'> November 2017 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2017/10/'> October 2017 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2017/09/'> September 2017 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2017/08/'> August 2017 &nbsp;(5)</option>
	<option value='https://noenthuda.com/blog/2017/07/'> July 2017 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2017/06/'> June 2017 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2017/05/'> May 2017 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2017/04/'> April 2017 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2017/03/'> March 2017 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2017/02/'> February 2017 &nbsp;(4)</option>
	<option value='https://noenthuda.com/blog/2017/01/'> January 2017 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2016/12/'> December 2016 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2016/11/'> November 2016 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2016/10/'> October 2016 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2016/09/'> September 2016 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2016/08/'> August 2016 &nbsp;(17)</option>
	<option value='https://noenthuda.com/blog/2016/07/'> July 2016 &nbsp;(4)</option>
	<option value='https://noenthuda.com/blog/2016/06/'> June 2016 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2016/05/'> May 2016 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2016/04/'> April 2016 &nbsp;(17)</option>
	<option value='https://noenthuda.com/blog/2016/03/'> March 2016 &nbsp;(17)</option>
	<option value='https://noenthuda.com/blog/2016/02/'> February 2016 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2016/01/'> January 2016 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2015/12/'> December 2015 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2015/11/'> November 2015 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2015/10/'> October 2015 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2015/09/'> September 2015 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2015/08/'> August 2015 &nbsp;(17)</option>
	<option value='https://noenthuda.com/blog/2015/07/'> July 2015 &nbsp;(20)</option>
	<option value='https://noenthuda.com/blog/2015/06/'> June 2015 &nbsp;(23)</option>
	<option value='https://noenthuda.com/blog/2015/05/'> May 2015 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2015/04/'> April 2015 &nbsp;(20)</option>
	<option value='https://noenthuda.com/blog/2015/03/'> March 2015 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2015/02/'> February 2015 &nbsp;(24)</option>
	<option value='https://noenthuda.com/blog/2015/01/'> January 2015 &nbsp;(35)</option>
	<option value='https://noenthuda.com/blog/2014/12/'> December 2014 &nbsp;(51)</option>
	<option value='https://noenthuda.com/blog/2014/11/'> November 2014 &nbsp;(32)</option>
	<option value='https://noenthuda.com/blog/2014/10/'> October 2014 &nbsp;(35)</option>
	<option value='https://noenthuda.com/blog/2014/09/'> September 2014 &nbsp;(30)</option>
	<option value='https://noenthuda.com/blog/2014/08/'> August 2014 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2014/07/'> July 2014 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2014/06/'> June 2014 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2014/05/'> May 2014 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2014/04/'> April 2014 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2014/03/'> March 2014 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2014/02/'> February 2014 &nbsp;(16)</option>
	<option value='https://noenthuda.com/blog/2014/01/'> January 2014 &nbsp;(17)</option>
	<option value='https://noenthuda.com/blog/2013/12/'> December 2013 &nbsp;(20)</option>
	<option value='https://noenthuda.com/blog/2013/11/'> November 2013 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2013/10/'> October 2013 &nbsp;(24)</option>
	<option value='https://noenthuda.com/blog/2013/09/'> September 2013 &nbsp;(27)</option>
	<option value='https://noenthuda.com/blog/2013/08/'> August 2013 &nbsp;(19)</option>
	<option value='https://noenthuda.com/blog/2013/07/'> July 2013 &nbsp;(17)</option>
	<option value='https://noenthuda.com/blog/2013/06/'> June 2013 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2013/05/'> May 2013 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2013/04/'> April 2013 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2013/03/'> March 2013 &nbsp;(16)</option>
	<option value='https://noenthuda.com/blog/2013/02/'> February 2013 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2013/01/'> January 2013 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2012/12/'> December 2012 &nbsp;(4)</option>
	<option value='https://noenthuda.com/blog/2012/11/'> November 2012 &nbsp;(1)</option>
	<option value='https://noenthuda.com/blog/2012/10/'> October 2012 &nbsp;(2)</option>
	<option value='https://noenthuda.com/blog/2012/09/'> September 2012 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2012/08/'> August 2012 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2012/07/'> July 2012 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2012/06/'> June 2012 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2012/04/'> April 2012 &nbsp;(4)</option>
	<option value='https://noenthuda.com/blog/2012/03/'> March 2012 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2012/02/'> February 2012 &nbsp;(3)</option>
	<option value='https://noenthuda.com/blog/2012/01/'> January 2012 &nbsp;(4)</option>
	<option value='https://noenthuda.com/blog/2011/12/'> December 2011 &nbsp;(23)</option>
	<option value='https://noenthuda.com/blog/2011/11/'> November 2011 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2011/10/'> October 2011 &nbsp;(26)</option>
	<option value='https://noenthuda.com/blog/2011/09/'> September 2011 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2011/08/'> August 2011 &nbsp;(22)</option>
	<option value='https://noenthuda.com/blog/2011/07/'> July 2011 &nbsp;(14)</option>
	<option value='https://noenthuda.com/blog/2011/06/'> June 2011 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2011/05/'> May 2011 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2011/04/'> April 2011 &nbsp;(16)</option>
	<option value='https://noenthuda.com/blog/2011/03/'> March 2011 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2011/02/'> February 2011 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2011/01/'> January 2011 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2010/12/'> December 2010 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2010/11/'> November 2010 &nbsp;(4)</option>
	<option value='https://noenthuda.com/blog/2010/10/'> October 2010 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2010/09/'> September 2010 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2010/08/'> August 2010 &nbsp;(4)</option>
	<option value='https://noenthuda.com/blog/2010/07/'> July 2010 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2010/06/'> June 2010 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2010/05/'> May 2010 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2010/04/'> April 2010 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2010/03/'> March 2010 &nbsp;(17)</option>
	<option value='https://noenthuda.com/blog/2010/02/'> February 2010 &nbsp;(5)</option>
	<option value='https://noenthuda.com/blog/2010/01/'> January 2010 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2009/12/'> December 2009 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2009/11/'> November 2009 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2009/10/'> October 2009 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2009/09/'> September 2009 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2009/08/'> August 2009 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2009/07/'> July 2009 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2009/06/'> June 2009 &nbsp;(14)</option>
	<option value='https://noenthuda.com/blog/2009/05/'> May 2009 &nbsp;(15)</option>
	<option value='https://noenthuda.com/blog/2009/04/'> April 2009 &nbsp;(19)</option>
	<option value='https://noenthuda.com/blog/2009/03/'> March 2009 &nbsp;(12)</option>
	<option value='https://noenthuda.com/blog/2009/02/'> February 2009 &nbsp;(19)</option>
	<option value='https://noenthuda.com/blog/2009/01/'> January 2009 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2008/12/'> December 2008 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2008/11/'> November 2008 &nbsp;(15)</option>
	<option value='https://noenthuda.com/blog/2008/10/'> October 2008 &nbsp;(22)</option>
	<option value='https://noenthuda.com/blog/2008/09/'> September 2008 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2008/08/'> August 2008 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2008/07/'> July 2008 &nbsp;(35)</option>
	<option value='https://noenthuda.com/blog/2008/06/'> June 2008 &nbsp;(24)</option>
	<option value='https://noenthuda.com/blog/2008/05/'> May 2008 &nbsp;(34)</option>
	<option value='https://noenthuda.com/blog/2008/04/'> April 2008 &nbsp;(27)</option>
	<option value='https://noenthuda.com/blog/2008/03/'> March 2008 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2008/02/'> February 2008 &nbsp;(31)</option>
	<option value='https://noenthuda.com/blog/2008/01/'> January 2008 &nbsp;(25)</option>
	<option value='https://noenthuda.com/blog/2007/12/'> December 2007 &nbsp;(22)</option>
	<option value='https://noenthuda.com/blog/2007/11/'> November 2007 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2007/10/'> October 2007 &nbsp;(15)</option>
	<option value='https://noenthuda.com/blog/2007/09/'> September 2007 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2007/08/'> August 2007 &nbsp;(19)</option>
	<option value='https://noenthuda.com/blog/2007/07/'> July 2007 &nbsp;(21)</option>
	<option value='https://noenthuda.com/blog/2007/06/'> June 2007 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2007/05/'> May 2007 &nbsp;(21)</option>
	<option value='https://noenthuda.com/blog/2007/04/'> April 2007 &nbsp;(20)</option>
	<option value='https://noenthuda.com/blog/2007/03/'> March 2007 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2007/02/'> February 2007 &nbsp;(19)</option>
	<option value='https://noenthuda.com/blog/2007/01/'> January 2007 &nbsp;(10)</option>
	<option value='https://noenthuda.com/blog/2006/12/'> December 2006 &nbsp;(14)</option>
	<option value='https://noenthuda.com/blog/2006/11/'> November 2006 &nbsp;(22)</option>
	<option value='https://noenthuda.com/blog/2006/10/'> October 2006 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2006/09/'> September 2006 &nbsp;(15)</option>
	<option value='https://noenthuda.com/blog/2006/08/'> August 2006 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2006/07/'> July 2006 &nbsp;(13)</option>
	<option value='https://noenthuda.com/blog/2006/06/'> June 2006 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2006/05/'> May 2006 &nbsp;(15)</option>
	<option value='https://noenthuda.com/blog/2006/04/'> April 2006 &nbsp;(30)</option>
	<option value='https://noenthuda.com/blog/2006/03/'> March 2006 &nbsp;(24)</option>
	<option value='https://noenthuda.com/blog/2006/02/'> February 2006 &nbsp;(41)</option>
	<option value='https://noenthuda.com/blog/2006/01/'> January 2006 &nbsp;(20)</option>
	<option value='https://noenthuda.com/blog/2005/12/'> December 2005 &nbsp;(11)</option>
	<option value='https://noenthuda.com/blog/2005/11/'> November 2005 &nbsp;(8)</option>
	<option value='https://noenthuda.com/blog/2005/10/'> October 2005 &nbsp;(24)</option>
	<option value='https://noenthuda.com/blog/2005/09/'> September 2005 &nbsp;(26)</option>
	<option value='https://noenthuda.com/blog/2005/08/'> August 2005 &nbsp;(18)</option>
	<option value='https://noenthuda.com/blog/2005/07/'> July 2005 &nbsp;(7)</option>
	<option value='https://noenthuda.com/blog/2005/06/'> June 2005 &nbsp;(19)</option>
	<option value='https://noenthuda.com/blog/2005/05/'> May 2005 &nbsp;(20)</option>
	<option value='https://noenthuda.com/blog/2005/04/'> April 2005 &nbsp;(6)</option>
	<option value='https://noenthuda.com/blog/2005/03/'> March 2005 &nbsp;(16)</option>
	<option value='https://noenthuda.com/blog/2005/02/'> February 2005 &nbsp;(9)</option>
	<option value='https://noenthuda.com/blog/2005/01/'> January 2005 &nbsp;(4)</option>
	<option value='https://noenthuda.com/blog/2004/12/'> December 2004 &nbsp;(1)</option>
	<option value='https://noenthuda.com/blog/2004/11/'> November 2004 &nbsp;(3)</option>
	<option value='https://noenthuda.com/blog/2004/10/'> October 2004 &nbsp;(2)</option>
	<option value='https://noenthuda.com/blog/2004/07/'> July 2004 &nbsp;(1)</option>

		</select>

<script>
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-4" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>

		</section><section id="categories-5" class="widget widget_categories"><h2 class="widget-title">Categories</h2><form action="https://noenthuda.com/blog" method="get"><label class="screen-reader-text" for="categories-dropdown-5">Categories</label><select  name='cat' id='categories-dropdown-5' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="6660">analytics&nbsp;&nbsp;(68)</option>
	<option class="level-0" value="5">arbit&nbsp;&nbsp;(730)</option>
	<option class="level-0" value="7699">baby&nbsp;&nbsp;(28)</option>
	<option class="level-0" value="12">bangalore&nbsp;&nbsp;(130)</option>
	<option class="level-0" value="4">blogging&nbsp;&nbsp;(62)</option>
	<option class="level-0" value="6661">book review&nbsp;&nbsp;(6)</option>
	<option class="level-0" value="27">books&nbsp;&nbsp;(60)</option>
	<option class="level-0" value="7">business&nbsp;&nbsp;(269)</option>
	<option class="level-1" value="34">&nbsp;&nbsp;&nbsp;retail&nbsp;&nbsp;(49)</option>
	<option class="level-0" value="6504">Business School WAG&nbsp;&nbsp;(3)</option>
	<option class="level-0" value="17">computer science&nbsp;&nbsp;(43)</option>
	<option class="level-0" value="6662">data&nbsp;&nbsp;(47)</option>
	<option class="level-0" value="11">descriptive&nbsp;&nbsp;(115)</option>
	<option class="level-0" value="6">economics&nbsp;&nbsp;(243)</option>
	<option class="level-0" value="39">education&nbsp;&nbsp;(57)</option>
	<option class="level-0" value="9">entertainment&nbsp;&nbsp;(71)</option>
	<option class="level-1" value="10">&nbsp;&nbsp;&nbsp;movies&nbsp;&nbsp;(31)</option>
	<option class="level-1" value="24">&nbsp;&nbsp;&nbsp;music&nbsp;&nbsp;(21)</option>
	<option class="level-0" value="7700">fatherhood&nbsp;&nbsp;(17)</option>
	<option class="level-0" value="42">favourites&nbsp;&nbsp;(6)</option>
	<option class="level-0" value="23">finance&nbsp;&nbsp;(166)</option>
	<option class="level-1" value="36">&nbsp;&nbsp;&nbsp;banking&nbsp;&nbsp;(23)</option>
	<option class="level-1" value="33">&nbsp;&nbsp;&nbsp;investment banking&nbsp;&nbsp;(54)</option>
	<option class="level-0" value="25">food&nbsp;&nbsp;(127)</option>
	<option class="level-0" value="20">fundaes&nbsp;&nbsp;(413)</option>
	<option class="level-0" value="3">general&nbsp;&nbsp;(696)</option>
	<option class="level-0" value="4430">history&nbsp;&nbsp;(5)</option>
	<option class="level-0" value="19">IIM&nbsp;&nbsp;(42)</option>
	<option class="level-0" value="18">IIT&nbsp;&nbsp;(45)</option>
	<option class="level-0" value="14">infrastructure&nbsp;&nbsp;(57)</option>
	<option class="level-0" value="21">language&nbsp;&nbsp;(39)</option>
	<option class="level-0" value="7880">London&nbsp;&nbsp;(4)</option>
	<option class="level-0" value="6663">mathematics&nbsp;&nbsp;(15)</option>
	<option class="level-0" value="38">media&nbsp;&nbsp;(35)</option>
	<option class="level-0" value="6802">Non-Quant&nbsp;&nbsp;(34)</option>
	<option class="level-0" value="6664">organization&nbsp;&nbsp;(7)</option>
	<option class="level-0" value="16">personal&nbsp;&nbsp;(314)</option>
	<option class="level-0" value="13">photowalk&nbsp;&nbsp;(16)</option>
	<option class="level-0" value="6665">platforms&nbsp;&nbsp;(54)</option>
	<option class="level-0" value="30">politics&nbsp;&nbsp;(137)</option>
	<option class="level-1" value="35">&nbsp;&nbsp;&nbsp;karnataka elections&nbsp;&nbsp;(12)</option>
	<option class="level-0" value="6666">Pricing&nbsp;&nbsp;(37)</option>
	<option class="level-0" value="26">quizzing&nbsp;&nbsp;(14)</option>
	<option class="level-0" value="15">randomness&nbsp;&nbsp;(88)</option>
	<option class="level-0" value="7051">regulation&nbsp;&nbsp;(9)</option>
	<option class="level-0" value="37">relationships&nbsp;&nbsp;(116)</option>
	<option class="level-0" value="31">religion&nbsp;&nbsp;(89)</option>
	<option class="level-0" value="4293">science&nbsp;&nbsp;(24)</option>
	<option class="level-0" value="5032">social networks&nbsp;&nbsp;(38)</option>
	<option class="level-0" value="8">sport&nbsp;&nbsp;(135)</option>
	<option class="level-1" value="44">&nbsp;&nbsp;&nbsp;contract bridge&nbsp;&nbsp;(3)</option>
	<option class="level-1" value="22">&nbsp;&nbsp;&nbsp;cricket&nbsp;&nbsp;(51)</option>
	<option class="level-2" value="41">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;ipl&nbsp;&nbsp;(14)</option>
	<option class="level-1" value="32">&nbsp;&nbsp;&nbsp;football&nbsp;&nbsp;(56)</option>
	<option class="level-1" value="28">&nbsp;&nbsp;&nbsp;tennis&nbsp;&nbsp;(4)</option>
	<option class="level-0" value="6667">sports analytics&nbsp;&nbsp;(29)</option>
	<option class="level-0" value="1935">studs and fighters&nbsp;&nbsp;(27)</option>
	<option class="level-0" value="3805">tank&nbsp;&nbsp;(42)</option>
	<option class="level-0" value="40">technology&nbsp;&nbsp;(48)</option>
	<option class="level-0" value="3144">travel&nbsp;&nbsp;(69)</option>
	<option class="level-0" value="1">Uncategorized&nbsp;&nbsp;(234)</option>
	<option class="level-0" value="6668">visualization&nbsp;&nbsp;(16)</option>
	<option class="level-0" value="29">work&nbsp;&nbsp;(133)</option>
</select>
</form>
<script>
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "categories-dropdown-5" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

			</section><section id="top-posts-2" class="widget widget_top-posts"><h2 class="widget-title">Top Posts &amp; Pages</h2><ul>				<li>
					<a href="https://noenthuda.com/blog/2020/04/30/the-corner-bhelpuri-guy/" class="bump-view" data-bump-view="tp">The corner Bhelpuri guy</a>					</li>
								<li>
					<a href="https://noenthuda.com/blog/2020/04/29/verandahs/" class="bump-view" data-bump-view="tp">Verandahs</a>					</li>
								<li>
					<a href="https://noenthuda.com/blog/2020/05/01/placing-data-labels-in-bar-graphs/" class="bump-view" data-bump-view="tp" aria-current="page">Placing data labels in bar graphs</a>					</li>
								<li>
					<a href="https://noenthuda.com/blog/2020/04/29/fulfilling-needs/" class="bump-view" data-bump-view="tp">Fulfilling needs</a>					</li>
								<li>
					<a href="https://noenthuda.com/blog/2020/04/24/tests-per-positive-case/" class="bump-view" data-bump-view="tp">Tests per positive case</a>					</li>
				</ul></section><section id="meta-9" class="widget widget_meta"><h2 class="widget-title">Meta</h2>			<ul>
						<li><a href="https://noenthuda.com/blog/wp-login.php">Log in</a></li>
			<li><a href="https://noenthuda.com/blog/feed/">Entries feed</a></li>
			<li><a href="https://noenthuda.com/blog/comments/feed/">Comments feed</a></li>
			<li><a href="https://en-gb.wordpress.org/">WordPress.org</a></li>			</ul>
			</section>	</aside><!-- .sidebar .widget-area -->
<script type='text/javascript'>
	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-4967586-1']);
_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>

		</div><!-- .site-content -->

		<footer id="colophon" class="site-footer" role="contentinfo">
							<nav class="main-navigation" role="navigation" aria-label="Footer primary menu">
					<div class="menu-main-container"><ul id="menu-main-1" class="primary-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6765"><a href="https://noenthuda.com/blog/contact/">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6766"><a href="https://noenthuda.com/blog/about/">About</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7573"><a href="https://noenthuda.com/blog/category/arbit/">arbit</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7574"><a href="https://noenthuda.com/blog/category/business/">business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-7575"><a href="https://noenthuda.com/blog/category/data/">data</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7576"><a href="https://noenthuda.com/blog/category/economics/">economics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7577"><a href="https://noenthuda.com/blog/category/fundaes/">fundaes</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7578"><a href="https://noenthuda.com/blog/category/randomness/">randomness</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7579"><a href="https://noenthuda.com/blog/category/religion/">religion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7580"><a href="https://noenthuda.com/blog/category/social-networks/">social networks</a></li>
</ul></div>				</nav><!-- .main-navigation -->
			
			
			<div class="site-info">
								<span class="site-title"><a href="https://noenthuda.com/blog/" rel="home">Pertinent Observations</a></span>
								<a href="https://en-gb.wordpress.org/" class="imprint">
					Proudly powered by WordPress				</a>
			</div><!-- .site-info -->
		</footer><!-- .site-footer -->
	</div><!-- .site-inner -->
</div><!-- .site -->

	<div style="display:none">
	<div class="grofile-hash-map-b8af9e1429e8886a4b26a805c933f8ef">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/noenthuda.com\/blog\/2020\/05\/01\/placing-data-labels-in-bar-graphs\/":9905};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/blog/2020/05/01/placing-data-labels-in-bar-graphs/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://noenthuda.com/blog/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<script>
		// Don't use Pocket's default JS as it we need to force init new Pocket share buttons loaded via JS.
		function jetpack_sharing_pocket_init() {
			jQuery.getScript( 'https://widgets.getpocket.com/v1/j/btn.js?v=1' );
		}
		jQuery( document ).ready( jetpack_sharing_pocket_init );
		jQuery( document.body ).on( 'post-load', jetpack_sharing_pocket_init );
		</script>
					<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_GB/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
			<script type="text/javascript">
			jQuery( document ).ready( function() {
				jQuery.getScript( 'https://platform.linkedin.com/in.js?async=true', function success() {
					IN.init();
				});
			});
			jQuery( document.body ).on( 'post-load', function() {
				if ( typeof IN != 'undefined' )
					IN.parse();
			});
			</script><script src='https://secure.gravatar.com/js/gprofiles.js?ver=202018'></script>
<script>
var WPGroHo = {"my_hash":""};
</script>
<script src='https://noenthuda.com/blog/wp-content/plugins/jetpack/modules/wpgroho.js?ver=62b1783c20b4e78dd36fca13d0c8b566'></script>
<script src='https://noenthuda.com/blog/wp-content/themes/twentysixteen/js/skip-link-focus-fix.js?ver=20170530'></script>
<script src='https://noenthuda.com/blog/wp-includes/js/comment-reply.min.js?ver=62b1783c20b4e78dd36fca13d0c8b566'></script>
<script>
var screenReaderText = {"expand":"expand child menu","collapse":"collapse child menu"};
</script>
<script src='https://noenthuda.com/blog/wp-content/themes/twentysixteen/js/functions.js?ver=20181217'></script>
<script src='https://noenthuda.com/blog/wp-includes/js/wp-embed.min.js?ver=62b1783c20b4e78dd36fca13d0c8b566'></script>
<script src='https://noenthuda.com/blog/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=8.4.2'></script>
<script src='https://noenthuda.com/blog/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=8.4.2'></script>
<script src='https://noenthuda.com/blog/wp-content/plugins/jetpack/_inc/build/likes/queuehandler.min.js?ver=8.4.2'></script>
<script async="async" src='https://noenthuda.com/blog/wp-content/plugins/akismet/_inc/form.js?ver=4.1.5'></script>
<script>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script src='https://noenthuda.com/blog/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=8.4.2'></script>
<script>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202018#ver=202018&amp;lang=en-gb' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=55712215&postid=9905&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Put+Comment&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_GB&jetpack_version=8.4.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=962e02d4fab69ad94de37c2440e3c023fc5e9d73#parent=https%3A%2F%2Fnoenthuda.com%2Fblog%2F2020%2F05%2F01%2Fplacing-data-labels-in-bar-graphs%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=55712215&postid=9905&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Put+Comment&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_GB&jetpack_version=8.4.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=962e02d4fab69ad94de37c2440e3c023fc5e9d73#parent=https%3A%2F%2Fnoenthuda.com%2Fblog%2F2020%2F05%2F01%2Fplacing-data-labels-in-bar-graphs%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202018.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.4.2',blog:'55712215',post:'9905',tz:'1',srv:'noenthuda.com'} ]);
	_stq.push([ 'clickTrackerInit', '55712215', '9905' ]);
</script>
</body>
</html>
